0

Not able to connect metamask with ganache-gui. I tried two different app images : ganache app image : ganache-2.5.4-linux-x86_64 and ganache-2.4.o-linux-x86_64 , neither seem to work . With ganache-2.5.4-linux-x86_64 I was getting error *

cannot connect to chain id please check rpc URL

  • , with ganache-2.4.0-linux-x86_64 its unable to connect (never ending loader as shown in image ).

Same errors faced with ganache-cli

Operating System: Ubuntu 20.04.1 LTS Kernel: Linux 5.8.0-50-generic Browser Brave

Tried uninstalling and reinstalling both ganache and metamask literally a thousand times . Would be much grateful if someone is able to answer

enter image description here

enter image description here enter image description here

Metmask network config : enter image description here

5
  • Can u show the network config of „ganache“ in metamask?
    – Majd TL
    May 10, 2021 at 8:50
  • Yess i ahve edited the post May 10, 2021 at 10:29
  • Http: and not http. ?
    – Majd TL
    May 10, 2021 at 12:38
  • I have tried everyting HTTP http https HTTPS May 10, 2021 at 13:57
  • I mean in the picture you are using a "point" after http -> "http." it should be "double "point" -> "http:"
    – Majd TL
    May 10, 2021 at 20:05

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.