0

I forked UniswapV2's factory and router and deployed them in Kovan using remix

addLiquidityETH

I also made sure that I am sending an ETH enter image description here

I also made sure that I approved the tokens enter image description here

But I am getting this error when trying to send the transaction enter image description here

When I proceed, the transaction always fail, here is one of them, it's returning a Fail with error 'UniswapV2Router: EXPIRED', this is the same error I am getting when doing the test in my local in truffle

https://kovan.etherscan.io/tx/0x59624fb39db924eff817f872001718cfaa95c825c052f21f4fd3cb033250d23b

Please take note that transactions are successful when using UniswapV2 Router's contract address in remix

2
  • Have you tried increase gas?
    – Stefdelec
    May 16 at 13:11
  • did you find any solution for this ? Jun 19 at 22:40
1

It seems to be a problem with the deadline, maybe the timestamp you are running the function on your computer is higher than the time you are setting as deadline.

Print the block.timestamp to know its value and get an idea of the possible error.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.