0

I'm experimenting with creating an ERC20 token and sending it over Ropsten test network using Metamask (following a basic tutorial). I was able to successfully create the token, deposit the tokens in my metamask wallet (wallet A), send it to another metamask wallet (wallet B) and have it appear there. However, when I try to send the tokens from wallet B back into wallet A, the tokens are deducted from wallet B but don't seem to ever actually get sent. I can continue to send coins from wallet A without a problem. Note, wallet B does have test ether in it from a faucet.

Any ideas on why I'm unable to send token? I'm not sure if this is a problem with how I set up the token or if this is a limitation of test network.

5
  • 1
    Can you share the transaction hashes? Do the wallets have enough balance to pay transaction fees?
    – Ismael
    May 7 at 1:18
  • Does this help? ropsten.etherscan.io/token/…
    – jaip
    May 7 at 4:01
  • And yes, I believe so. There's 1 test ether and the gas fee for the transaction I just tried was well below that.
    – jaip
    May 7 at 4:02
  • 1
    I see nothing wrong, the transactions they were successful, and the accounts A=0x16c2 and B=0xa079 exchanged some tokens. It appears to be working, why do you say you cannot send tokens?
    – Ismael
    May 7 at 4:15
  • 1
    You're right, I didn't even notice! I got confused b/c the activity section in wallet A didn't show any tokens being received and wallet B didn't confirm the transaction worked but the balances appears to be correct now. Thanks for your help!
    – jaip
    May 7 at 16:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.