3

I use official tutorial to run Ethereum private network: https://geth.ethereum.org/docs/getting-started/private-net but the command :

geth --datadir="/home/user/1" -verbosity 6 --ipcdisable --port 30301 --http.port 8101 console 2>> /home/user/1/01.log

return error:

Incorrect Usage. flag provided but not defined: -http.port

WAIDW?

upd. : upgrading of geth fith problem

3
  • Hi there. Which version of Geth are you using? Commented Apr 16, 2021 at 8:03
  • You right. I upgrade geth and problem dissapeared
    – user216
    Commented Apr 16, 2021 at 8:17
  • Perfect - glad it helped :-) Commented Apr 16, 2021 at 8:18

1 Answer 1

5

The names of the HTTP/RPC-related options were changed in Geth v1.9.19 under #21105.

From:

  --rpc                  
  --rpcaddr value        
  --rpcport value        
  --rpcapi value         
  --rpc.gascap value     
  --rpccorsdomain value  
  --rpcvhosts value      

To:

  --http                            
  --http.addr value                 
  --http.port value                 
  --http.api value                  
  --http.rpcprefix value            
  --http.corsdomain value           
  --http.vhosts value

Either update Geth, or use the --rpcport option instead. (I'd recommend the former.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.