3

At this point I've given up any hope.

I've tried syncing with geth --fast --cache=1024. I have ~99% synchronization and the remaining ~1% (the last 1000-2000 blocks) is taking forever.

With Parity 1.3.9 --geth I've gotten to a block ~2 420 000 with a rate 200 blocks/second (it took just a couple of hours) and after this point I'm getting 0-1 blocks/second.

What's the problem? Does it have to do with the ongoing attacks or is it the result of the previous attacks that bloated the blockchain? Or is it something else?

  • 1) Are you running on a hard disk drive or a solid state drive? 2) Have you updated your software to the latest version after the gas reprice hard fork (blog.ethereum.org/2016/10/18/faq-upcoming-ethereum-hard-fork) ? 3) How much memory do you have on your computer? 4) Did you clear your old blockchain completely before trying to --fast sync? – The Officious BokkyPooBah Oct 30 '16 at 6:20
  • 1
    @BokkyPooBah, yeah, I have HDD. I guess the problem might be there. Hovewer, I don't understand how ~200x drop in sync speed can be attributed to using HDD. It's not like the performance of HDD is 200x times lower than that of SDD. Anyway, thank you, BokkyPooBaa! I'll wait for the parity 1.4 and their --warp-sync option) – manidos Oct 30 '16 at 7:15
  • 1
    From blog.ethereum.org/2016/09/22/transaction-spam-attack-next-steps, blocks that take up to ~20-60 seconds to validate due to the ~50,000 disk fetches needed to process the transaction. And from photographylife.com/nvme-vs-ssd-vs-hdd-performance, Where SSDs shine is random read/write: at 4K, SSDs in your example have 50× read speed and 82× write speed over HDDs. – The Officious BokkyPooBah Oct 30 '16 at 13:50