5

Can't Use "Eth Console" Command upon Installing Eth with Spacebrew

Hi everyone, I'm learning how to create my own d'apps on the Ethereum blockchain as part of a Master's thesis research process. So far I've been taking tutorials with geth and Mist, but am now moving into Eth and Mix for the C++ implementation.

I've already successfully installed geth with spacebrew and can use it normally from the command line.

I just tried to install eth using the instructions from the github and was able to successfully compile using spacebrew.

However, when I try to run

eth console

as per the instructions, I keep getting the error, "Invalid Argument: console".

I've tried using

eth --console
eth -console
eth console --frontier
eth console --testnet

all with similar results, and have made sure to upgrade and update spacebrew.

I've looked all over for someone with a similar problem, but can't find anything in the forums.

Does anyone have any insight?

1

Only geth has a javascript console.

If you want to connect to eth or parity, simply run them:

$ eth

Or:

$ parity --geth

And after that you can use geth to attach a console to the c++ or rust client, like that:

$ geth attach

The output will look like this:

$ geth attach
Welcome to the Geth JavaScript console!

instance: eth/v1.3.0/Linux/g++/Interpreter/RelWithDebInfo/27da2620/
coinbase: 0x00243db98c4182ebc1d5abd921f986814c3bd7b9
at block: 1719189 (Fri, 17 Jun 2016 08:18:45 CEST)
 modules: admin:1.0 db:1.0 debug:1.0 eth:1.0 miner:1.0 net:1.0 personal:1.0 shh:1.0 web3:1.0

> 

Note the 3rd line, telling you that you just attached to an eth instance.

0

ethconsole is one word, and seems to be a javascript interpreter.

eth on the other hand is a compiled, linked, and installed executable. Both are launched from the command line (in linux at least), but the parameter contexts are different.

eth uses the standard-style unix 'switch' command parameters, but ethconsole requires a weird asynchronous (call-back loaded) object-style string with a brief error-handler subsection at the end.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.