7

Mist shows that I have 1 ETH in my account. When I check etherscan see exactly 0.99895 ether in my account....

I would like to send all 0.99895 ether to another address. When I try to send exactly that amount, I get an error saying not enough funds.

MIST also shows me "0.00105 ETHER FEE". When I deduct that from the total (try to send 0.99790) it also tell me not enough funds.

How on earth do I sent this entire amount? Thanks!

6

In order to send Ether, you need to pay a transaction fee of 21k gas (more if you are sending to or from a contract-based wallet).

Mist rounds some Ether values, so it is very difficult to send exactly the amount in your wallet. To send roughly the amount you want, just lower the transaction value by 0.0001 ETH or so, or reduce the transaction fee by sliding the "select fee" slider left.

If you really want precision, you can use the command line client that is packaged with Mist. Open up your command line, and cd into the ./resources/node/geth/ directory. Then run

./geth --exec "eth.sendTransaction({from:'0xADDRESS',to:'0xRECIPIENT',value:eth.getBalance('0xADDRESS')-21000*50000000000-1,gas:21000,gasPrice:50000000000})" --unlock '0xADDRESS' console

Replace both instances of ADDRESS and RECIPIENT with your address and the recipient's address respectively. Leave the quotation marks.

  • Thanks! I think I'm most of the way there. I'm on Windows 10 for starters. I ran the command and received an error: Invalid ' '0xADDRESS' ' - It shows two quotation marks at each end just like I have copied here.... – CryptoKrate Feb 4 '16 at 2:23
  • Did you replace ADDRESS with your address? And made sure to copy it correctly? – Tjaden Hess Feb 4 '16 at 2:26
  • Yes, and I get this exact error: Fatal: Invalid account address ''0xADDRESS'' - accept I have copied my exact address out of MIST. – CryptoKrate Feb 4 '16 at 2:33
  • I don't think you replaced all instances of ADDRESS. I edited the code, so now you just need to replace ADDRESS twice and RECIPIENT once. Keep the '0x' in front. – Tjaden Hess Feb 4 '16 at 2:43
  • What you pasted resulted in the same error. However, I removed the " around the ADDRESS for the unlock flag, I got it to prompt me for my passphrase. After successful unlock I got this error: pastebin.com/raw/XJLxEUMN – CryptoKrate Feb 4 '16 at 2:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.