10

Issue started after installing cpp-ethereum & updating geth to 1.3.3. Geth continually re-opens in the background after being forced to shut down. When I try and run geth in terminal, I receive the following error:

Fatal: Error starting Ethereum: listen udp :30303: bind: address already >in use (possibly another instance of geth is using the same port)

Tried a hard re-start, after which geth re-opened in the background again. Tried uninstalling cpp-ethereum and uninstalling geth (both 1.3.3 and the previous 1.2.2). As soon as it is reinstalled, geth opens up in the background.

Open to any and all suggestions!

  • How are you installing Geth? – Maran Feb 3 '16 at 13:44
  • using brew, e.g. ---- '==> Installing ethereum from ethereum/ethereum ==> Downloading build.ethdev.com/builds/bottles/ethereum-1.3.3.yosemite. Already downloaded: /Library/Caches/Homebrew/ethereum-1.3.3.yosemite.bottle.8.tar.gz ==> Pouring ethereum-1.3.3.yosemite.bottle.8.tar.gz ==> Caveats To reload ethereum/ethereum/ethereum after an upgrade: launchctl unload ~/Library/LaunchAgents/homebrew.mxcl.ethereum.plist launchctl load ~/Library/LaunchAgents/homebrew.mxcl.ethereum.plist ==> Summary 🍺 /usr/local/Cellar/ethereum/1.3.3: 18 files, 87.0M' – jjms Feb 3 '16 at 17:05
  • 1
    launchctl unload ~/Library/LaunchAgents/homebrew.mxcl.ethereum.plist should hopefully prevent geth from booting on restart. Could you try that? – Maran Feb 3 '16 at 17:12
8

When you install geth via the brew package it sets up an automatic launch script so Geth launches during boot.

If this is not desirable you can disable it using:

launchctl unload ~/Library/LaunchAgents/homebrew.mxcl.ethereum.plist

If this does not do the trick, then open the homebrew.mxcl.ethereum.plist file (for example in Xcode) and change the Boolean values of RunAtLoad and KeepAlive from 'true' to 'false'.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.