I'm trying to install a solidity compiler on my Mac. I've followed the guide here: https://github.com/ethereum/go-ethereum/wiki/Contract-Tutorial

The error that I've gotten when installing ccp-ethereum is "Error: No formulae found in taps."

zhongqin-imac:~ ngzhongqin$ brew install cpp-ethereum
Error: No available formula with the name "cpp-ethereum" 
==> Searching for similarly named formulae...
Error: No similarly named formulae found.
==> Searching taps...
Error: No formulae found in taps.
up vote 20 down vote accepted

From Solidity - Binary Packages:

brew update
brew upgrade
brew tap ethereum/ethereum
brew install solidity
  • This worked great. Minor comment, on the last line I got Warning: brew linkapps has been deprecated and will eventually be removed! -- but it worked fine for me without this. – Harlan T Wood Apr 11 '17 at 21:03
  • 1
    If you need a specific version, then you'll need to find the specific commit corresponding to your version of this file: github.com/ethereum/homebrew-ethereum/commits/master/… then get the raw URL, and run brew install https://raw.githubusercontent.com/ethereum/homebrew-ethereum/de1da16f7972a899fc8dd1f3f04299eced6f4312/solidity.rb – maurelian Nov 23 '17 at 15:46
  • 1
    brew linkapps is deprecated – Rexcirus Oct 10 at 10:56
  • @Rexcirus Removed brew linkapps – The Officious BokkyPooBah Oct 11 at 12:51

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.