4

I have cloned the cpp-ethereum in Linux (centOS) from git as follows as suggested in cpp-ethereum-develop cmake error

git clone https://github.com/ethereum/cpp-ethereum 

cd cpp-ethereum

git checkout 5669c209f4f8dbb7dc3f744e8e2a9c92f1104ca3

git checkout -b develop

git submodule update --init --recursive

mkdir -p build
cd build

git clone https://github.com/cinemast/libjson-rpc-cpp

cmake .. 

When building, I get:

-- Could NOT find jsoncpp (missing:  JSONCPP_LIBRARY JSONCPP_INCLUDE_DIR) 

-- JsonCpp headers: JSONCPP_INCLUDE_DIR-NOTFOUND

-- JsonCpp lib   : JSONCPP_LIBRARY-NOTFOUND


CMake Error at cmake/UseJsoncpp.cmake:8 (message):

  Jsoncpp library not found
Call Stack (most recent call first):

  cmake/EthDependencies.cmake:203 (eth_apply)

  cmake/UseJsonRpc.cmake:3 (eth_use)

  cmake/EthDependencies.cmake:203 (eth_apply)

  eth/CMakeLists.txt:7 (eth_use)

Is the above problem from path setting or some thing else?

1
  • please share the procedure you followed to install the ethereum cpp and which option did you use
    – Badr Bellaj
    Oct 21, 2016 at 14:55

1 Answer 1

1

you need to install JSON-RPC (remote procedure call) support for C++ :

https://github.com/cinemast/libjson-rpc-cpp

7
  • after installing the above, same error is thrown.
    – userven
    Oct 23, 2016 at 7:15
  • past the errors in comment and show to commands you used in the procedure
    – Badr Bellaj
    Oct 23, 2016 at 9:01
  • above are the errors and procedure I followed.
    – userven
    Oct 26, 2016 at 12:01
  • you get the same error even after installing the json rpc?
    – Badr Bellaj
    Oct 26, 2016 at 12:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.