0

Firstly, I have created a node in quorum private blockchain and initiated genesis to create blockchain using geth and bootnode . Then, I run the node and it is running blockchain. Later, I tried to peer with the existing node,then I connected it with few other nodes it is working fine.(Genesis file, networkid is same for all enodes).

After that it is showing "leader is undefined" and

other error is "rafthttp: failed to find member 1 in cluster 1000".

and another anomaly is while adding the existing peer to the cluster again (just to see its ID) it has created a raft id and appeared again in cluster(actually it should show the error but created twice the enode) enter image description here

by looking into above you can see two times enode, raftid 4 and 12, created( I think it is bug in geth 20.0 version but later I have updated with geth 21 version). #how to resolve it enter image description here

If I tried to remove the same enode but it is displaying blank screen and same with other raftids. # how to resolve this error

enter image description here

if I tried to peer with the existing node it is showing like this failed to find member . # how to solve this

my command to this for connecting to peer PRIVATE_CONFIG=ignore geth --datadir /home/ctquorumadmindev/QuorumChain/Test-Node2 --nodiscover --verbosity 5 --networkid 786 --raft --raftport 50501 --raftjoinexisting 2 --rpc --rpcaddr 0.0.0.0 --rpcport 8501 --rpcapi admin,db,eth,debug,miner,net,shh,txpool,personal,web3,quorum,raft --emitcheckpoints --port 25501 --ws --wsaddr 0.0.0.0 --wsport 8551 --wsapi=db,eth,net,web3,txpool,miner,admin,personal,web3 --wsorigins=*

my static node is this enter image description here

main node //4ce4a5764647f418076a233a30fc34fcaa8f11d091440e5553c658d43faec60edc3992e373737716d6f4865b7606129ed1d5495819696216bd716960b20a341b is running but others are not connecting to this cluster above mentioned raft cluster is depicted for this scenario. # how to solve this

some other info that may help you:

*multiple times I created raftId and removed it

*I tried to peer with new nodes it is showing same error

I have tried my best to explain current scenario, if any extra info needed I will be available to you

0

you can delete the raft files on all nodes and restart the clustering of node, no blockchain data can be lost.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.