2

I'm running geth 1.4.17-stable. Also running Mist 0.8.6. While geth finished fast syncing up a few hours ago, it's still eating away at my laptop's CPU. Note I'm not trying to mine.

Is that normal for geth or is there anything I can do to reduce its CPU usage?

top

Thanks!

2

After Syncing, geth is trying to mine (calculating hashes to get a succesfull block and its reward). Mining requires lot of computation power due to the HASH calculation.

That's the reason.

| improve this answer | |
  • I'm not trying to mine. I thought geth mines only if I pass the --mine flag, is that not right? – ronme Oct 18 '16 at 6:55
  • Or by sending miner.start console command. Are you sure geth is not trying to mine? What net are you connected to? – KanekiDev Oct 18 '16 at 6:58
  • Thanks, I don't know that I sent a minder.start command. I believe I'm connected to the main (prod) network, as I'm able to see balances etc. In general, I just ran geth --fast first time, or geth in subsequent times, so all the default options should have kicked in I guess...? – ronme Oct 18 '16 at 7:21
  • Probably that's the reason. You can try this command: geth --fast console It gives you a console commands, then after syncing ensure you are not mining by using miner.stop. But if you are "playing" on the main net, then the syncing will keep forever (as new blocks are being mined by other nodes). – KanekiDev Oct 18 '16 at 7:33
  • I understand syncing goes on and that's fine, I just hoped syncing doesn't eat so many resources. Actually, now for some reason it calmed down, eating only 5%ish CPU. Thanks @KanekiDev! – ronme Oct 18 '16 at 16:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.