0

I am new here, and this is my first question.

I have just installed ethminer on ubuntu 20.04 and it seems that everything is ok in the settings:

  1. The command ethminer --list-devices gives
ethminer 0.19.0-17+commit.ce52c740
Build: linux/release/gnu

 Id Pci Id    Type Name                          CUDA SM   Total Memory 
--- --------- ---- ----------------------------- ---- ---  ------------ 
  0 03:00.0   Gpu  GeForce GTX 1070              Yes  6.1       7.37 GB 
  1. Running a benchmark with the commad ethminer -G -M 0 works well

  2. Moreover clinfo gives the following

Number of platforms                               1
  Platform Name                                   NVIDIA CUDA
  Platform Vendor                                 NVIDIA Corporation
  Platform Version                                OpenCL 1.2 CUDA 11.2.109
  Platform Profile                                FULL_PROFILE

Nevertheless when I try to really run ethminer by typing for example:

ethminer -G --report-hr -P stratum1+tcp://XXXXXXXXXXXXXXXXXX.@eth-eu1.nanopool.org:9999

then I get:

ethminer 0.19.0-17+commit.ce52c740
Build: linux/release/gnu

Error: No usable mining devices found

Do you have any idea on what is happening here?

1
  • Did you found a solution? can you post it ?
    – fdjfijdf93
    Mar 20 '21 at 18:45
0

Change -G for -U. This worked for me.

1
  • 2
    Hello. While this might answer the question, more details would be nice to understand why this works. Jul 15 '21 at 9:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.