4

I'm brand new to Ethereum, and come from the Bitcoin world.

I installed geth and Mist today (0.8.5, 64-bit builds for Windows), and successfully sent some Ethereum to my Etherbase account from an exchange. It's there in Mist.

But I'm having trouble sending Ethereum back out from my account using Mist.

e.g. I tried sending 1 ETH to an address, and choose the highest fee available in the client (~0.004 ETH). It showed my transaction as "sent" but it sat there for several minutes with 0 confirmations, until it finally complained that the transaction "couldn't be successfully executed" and rolled it back.

Is my fee too low, and is there a way to increase it beyond the maximum available in the client? Is there a log or some way to see exactly why my transaction failed?

In case it's relevant, I did move my data directory to another drive and am starting up the client via:

start "geth" "C:\Users\blah\AppData\Local\Mist\app-0.8.5\nodes\geth\win-x64\geth.exe" --datadir X:\EthereumData
start "Mist" "C:\Users\blah\AppData\Local\Mist\app-0.8.5\Mist.exe" --datadir X:\EthereumData

I saw some stuff about an ipc parameter and am not sure if I'm missing it above. I figured since everything else seemed to be working between geth and Mist I'm ok on that front.

  • A few minutes after posting this Mist 0.8.6 was released. I switched to that (and geth "Note 7") and it worked. Maybe someone can explain what was going on before (was I experiencing the effects of a network crippled by a DDOS attack?), and for bonus points, why geth no longer seems to be included in the Mist 64-bit binary...? – rkagerer Oct 16 '16 at 20:35
  • And... it seems after the upgrade, my prior attempts went through (after Mist already had told me they'd failed!). Either I'm doing this wrong, or the client has some serious wonkiness. If this was a payment to someone else I would have unknowingly sent them ~3x as much as owed, by this point! – rkagerer Oct 16 '16 at 21:17
  • Wow this gets even more interesting. After my Account ran out of currency, "replay" of the prior attempts ceased. But then HOURS later when I funded some more Ethereum into my Account, the silly client went ahead and completed the remaining attempts that it had already told me failed. Seems super unintuitive. Is it just me, or does this client need some work to give a better picture to the user of what's going on? – rkagerer Oct 17 '16 at 1:20
  • Feel free to answer your own question if your problem is solved. – Waqar Lim Nov 10 '16 at 10:19
  • Issue seems to be back in some form : "The transaction from Main account (Etherbase) to Account 2 couldn't be successfully executed" – Martin Haeberli May 31 '17 at 20:04
1

Well, the network was under DoS attacks for several weeks now. They spammed the nodes with special transactions exploiting too low gas costs for several operations. Miners decided to stop including transactions in any block because that cause their nodes to crash or get stuck.

Yesterday (Oct-19, 2016) was a hard fork to mitigate that attack by increasing gas costs for several operations. After block 2,463,000 your wallet will go back to normal work. Pools already started rasing the gas limits and include transactions again. Please let me know if this issue exists after oct-19, 2016 and we could look deeper into that.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.