0

I started syncing geth with this command he command:

geth --rpc --etherbase <pulbic wallet adrress> --syncmode=fast --cache=2048

and about 25 hours later, the syncing stopped and this error showed up: https://pastebin.com/YGUiexQD

so I ran the command again to resume it but it didn't continue syncing, instead, it gave me this error (it's not the exact same text as the last one but it's similar): https://pastebin.com/PrtxpFu7

It isn't a problem with the available storage because I have around 100 MB of storage free.

I asked in the Geth discord server for help and one of the people there told me it could be a problem with the ram or a problem with the checksum. I ran the memory diagnostics program and there weren't any problems so it must have been a problem with the checksum.

I checked the Checksum of geth.exe and compared it to what was written in https://geth.ethereum.org/downloads/ (Windows 64 bit installer geth 1.9.25) and it wasn't the same.

The checksum of geth.exe is: 89e048a0176ac1c92812eb4141c190b6

While the checksum on the website and the installer is for the same version is: 89e048a0176ac1c92812eb4141c190b6

Is that ok? or is it a problem with my installation? If it is, how do I download the correct one? I tried downloading it again and installing geth again but still the same result.

If the problem isn't with the checksum after all so what is it?

Thanks for your time people!

2
  • geth has a lot of memory management issues when you set the --cache flag, this is mostly due to Golang allocating memory twice for the garbage collector. Set the --cache value much lower than your available memory, otherwise you are going to get memory swapped and finally get out of mem error
    – Nulik
    Feb 1 at 16:12
  • 1
    Checksum has nothing to do, you are probably calculating it incorrectly
    – Nulik
    Feb 1 at 16:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.