3

enter image description here

I am using home brew to install ethereum but it keeps returning this error. Is there anyway I can fix it?

  • Try the non-dev installation. – The Officious BokkyPooBah Oct 15 '16 at 3:43
  • @BokkyPooBah Where would I find that ? Forgive me If the question seems stupid. I am in fact a non-dev trying to become one. – iivri andre Oct 18 '16 at 3:49
1

The instructions for the non-dev version can be found at Installation Instructions for Mac and follows:

brew tap ethereum/ethereum
brew install ethereum

While I'm writing this, I may as well add in the upgrade instructions:

brew update
brew upgrade ethereum

To find out the installation information:

brew info ethereum


Troubleshooting Update

  1. What does brew doctor report? Does it ask you to execute commands line the following to fix up user permissions?

    sudo chown -R $(whoami) /Users/bok/Library/Caches/Homebrew
    

    There is a possibility that brew is unable to create the required files in directories with incorrect permissions.

  2. From my $HOME directory, when I type the following command, I have an env.sh file:

    Iota:~ bok$ find . -name 'env.sh'
    ./Library/Caches/Homebrew/ethereum--git/build/env.sh
    

    and the contents of this file follows:

    Iota:~ bok$ more ./Library/Caches/Homebrew/ethereum--git/build/env.sh
    #!/bin/sh
    
    set -e
    
    if [ ! -f "build/env.sh" ]; then
        echo "$0 must be run from the root of the repository."
        exit 2
    fi
    
    # Create fake Go workspace if it doesn't exist yet.
    workspace="$PWD/build/_workspace"
    root="$PWD"
    ethdir="$workspace/src/github.com/ethereum"
    if [ ! -L "$ethdir/go-ethereum" ]; then
        mkdir -p "$ethdir"
        cd "$ethdir"
        ln -s ../../../../../. go-ethereum
        cd "$root"
    fi
    
    # Set up the environment to use the workspace.
    # Also add Godeps workspace so we build using canned dependencies.
    GOPATH="$workspace"
    export GOPATH
    
    # Run the command inside the workspace.
    cd "$ethdir/go-ethereum"
    PWD="$ethdir/go-ethereum"
    
    # Launch the arguments with the configured environment.
    exec "$@"
    

    You could try creating the file above in the same directory on your computer, then run chmod 755 ./Library/Caches/Homebrew/ethereum--git/build/env.sh to make it an executable file. Then re-run youir brew install ethereum.

    You can download this same file from https://github.com/ethereum/go-ethereum/blob/master/build/env.sh.

  3. You may want to download the Xcode application from your app store. If you have already done this, make sure your have the 8.0 update - check your app store update list.

  4. Looking at the URL provide in your error report https://git.io/brew-troubleshooting:

    • Run brew update (twice) and brew doctor before creating an issue!
  5. brew doctor earlier told me that I needed to update my command line tools:

    Iota:Downloads bok$ brew doctor
    ....
    Warning: You have Xcode 8 installed without the CLT;
    this causes certain builds to fail on OS X El Capitan (10.11).
    Please install the CLT via:
      sudo xcode-select --install
    Iota:Downloads bok$ sudo xcode-select --install
    xcode-select: note: install requested for command line developer tools
    
  6. Looking at https://github.com/ethereum/homebrew-ethereum/issues, you have already reported this issue in Unable to install go-ethereum #89.

  7. The issue with Unexpected header files: /usr/local/include/python2.7/greenlet/greenlet.h seems to not be a serious problem - see https://github.com/Homebrew/legacy-homebrew/issues/38152 .

  8. If you want to use geth while your brew install ethereum is not working, you can install Ethereum Wallet on your computer from Ethereum Wallet 0.8.6, and the first time you start Ethereum Wallet, it will download your geth binary. You will however not have the Solidity compiler solc:

    Iota:unpacked bok$ pwd
    /Users/bok/Library/Application Support/Ethereum Wallet/binaries/Geth/unpacked
    Iota:unpacked bok$ ll
    total 72784
    drwxr-xr-x  6 bok  staff       204 17 Oct 09:58 .
    drwxr-xr-x  4 bok  staff       136 17 Oct 09:58 ..
    -rw-r--r--  1 bok  staff     32397 16 Oct 20:19 COPYING
    -rw-r--r--  1 bok  staff      7651 16 Oct 20:19 COPYING.LESSER
    -rwxr-xr-x  1 bok  staff  18611260 17 Oct 09:58 geth
    -rwxr-xr-x  1 bok  staff  18611260 16 Oct 20:07 geth-1.4.18-stable-c72f545-darwin-10.6-amd64
    Iota:unpacked bok$ ./geth version
    Geth
    Version: 1.4.18-stable-c72f5459
    ...
    
  • I tried both of those but it keeps giving me this error. Last 15 lines from /Users/iivri.andre/Library/Logs/Homebrew/ethereum/02.make: 2016-10-17 22:46:10 -0500 make all build/env.sh go run build/ci.go install make: build/env.sh: No such file or directory make: *** [all] Error 1 – iivri andre Oct 18 '16 at 11:43
  • This is the error I got when I ran brew doctor /Users/iivri.andre/Desktop/Screen Shot 2016-10-18 at 8.36.34 PM.png – iivri andre Oct 19 '16 at 1:38
  • This is the error I got when I ran brew doctor Andres-MacBook-Air:~ iivri.andre$ brew doctor Please note that these warnings are just used to help the Homebrew maintainers with debugging if you file an issue. If everything you use Homebrew for is working fine: please don't worry and just ignore them. Thanks! Warning: Unbrewed header files were found in /usr/local/include. If you didn't put them there on purpose they could cause problems when building Homebrew formulae, and may need to be deleted. Unexpected header files: /usr/local/include/python2.7/greenlet/greenlet.h – iivri andre Oct 19 '16 at 1:39
  • I am not getting any response from anyone on github. This is frustrating – iivri andre Oct 19 '16 at 1:42
  • See updated answer – The Officious BokkyPooBah Oct 19 '16 at 2:20
0

I solve the problem using by following instructions below. I don't know the reason, but I completely get rid of brew to make it run. (mac)

  1. install go(I used package)
  2. git clone https://github.com/ethereum/go-ethereum
  3. cd go-ethereum && git checkout tags/v1.8.2
  4. run find . -type f -print0 | xargs -0 -n 1 -P 4 dos2unix(if you don't have dos2unix, you could brew one, it does not break anything.)
  5. make geth
  6. ln -s /path/to/origin/geth /path/to/target/geth

Then run which geth you could find your geth. Run geth version you can see your version.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.