0

My Ethereum node was fast synced one year ago and then ran for 10 months, before that computer was shut down.

I have turned on that computer and I want to continue catching up, but Geth keeps switching from fast sync to full sync. I think that it merely checks whether it had begun full syncing at the end of the last fast sync, and now I have a year to catch up to with full sync that I don't want, because it is too slow.

How do I force Geth to use fast sync? Without starting over from scratch

the command I am using is

geth --syncmode "fast" --cache=8192 --http --http.addr 127.0.0.1 --http.port "8545" --maxpeers=50

but this is what the output says

WARN [01-09|04:35:31.697] Switch sync mode from fast sync to full sync

and although that seems like it would be merely an informative suggestion, it is clear that it is doing a full sync from 10 months ago and that this will take a long time

Version: 1.9.24
Git Commit: 889f5645b57dde5b5d4cccf1561bdb449293d2d8
Git Commit Date: 20210108
Architecture: amd64
Go Version: go1.15.6
Operating System: linux```
1

You can set the fast sync mode for the first time when starting from initialization. Since your node has already reached the state of synchronization with the chain, it has already been switched to full synchronization earlier. Therefore, no matter what, geth continues to run in full. Now, if you want to load the chain in fast mode, you need to completely delete the data and reload it in fast mode.

3
  • that's ridiculous. – CQM Jan 10 at 7:11
  • If the principle of synchronization inherent in ethereum makes you laugh. Good luck! – foreston Jan 10 at 7:13
  • I want to option to override full-sync. you are appealling to the authority of geth and acting like this is "the principle of synchronizations inherent in ethereum" when this is a feature or bug specifically in geth there are other clients, turbo-geth is working on snapshot syncing. I'm just asking to clarify if geth is limited in this way currently and am still collecting opinions. mainly to see if that community would be interested in patching it – CQM Jan 10 at 16:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.