1

I used to run a node on my Mac by simply typing geth console on the cli. However, I had to stop running geth about a month ago when the DOS attacks started. Last week though, I downloaded and installed Parity and I run it by typing parity --geth on the cli. But now, when I try to run geth using the old way (i.e. by typing geth console), I get an error message. When I go into my Mist folder, I don't see geth in there anymore. There is a geth in the Parity folder though. So I downloaded the latest version of geth and it's sitting in my Application folder, and I can't seem to run it from the cli like before. Could you please let me know what I need to do so that I can run geth exactly as I had before and where I should move the geth executable file to as it is sitting in my Applications folder?

  • what is the message error do you get? – Badr Bellaj Oct 11 '16 at 19:44
  • I'm not getting an error now for some reason. Now it just says "Welcome to the Geth JavaScript console!" and below the prompt ">" shows up but just hangs there. Nothing happens. What to do? – JDawg Oct 11 '16 at 20:09
2

don't worry just re-download geth without Mist. add the folder where you put it into the Path. don't run geth alongside parity. run parity --geth (Geth-IPC-compatibility mode) first and use **geth attach** to get a console to execute your scripts and commands.

  • I did what you suggested and maybe I did something wrong because after I add the folder to the Path and typed "geth console" in the cli, I got: – JDawg Oct 11 '16 at 22:07
  • fatal error: unexpected signal during runtime execution fatal error: unexpected signal during runtime execution [signal 0xb code=0x1 addr=0xb01dfacedebac1e pc=0x4027bab] runtime stack: runtime.throw(0x4d93f00, 0x2a) /usr/local/opt/go/libexec/src/runtime/panic.go:547 +0x90 runtime.sigpanic() /usr/local/opt/go/libexec/src/runtime/sigpanic_unix.go:12 +0x5a runtime.unlock(0x540d220) /usr/local/opt/go/libexec/src/runtime/lock_sema.go:107 +0x14b runtime.(*mheap).freeSpan.func1() /usr/local/opt/go/libexec/src/runtime/mheap.go:726 +0x186 runtime.systemstack(0x7000028f0b30) – JDawg Oct 11 '16 at 22:10
  • The output was a lot longer but it went over my allotted character limit... – JDawg Oct 11 '16 at 22:10
  • tried it again and block synchronization started. bizarre... now it hangs again so back to square one. – JDawg Oct 11 '16 at 22:20
  • check if you run of space...or something related – Badr Bellaj Oct 11 '16 at 22:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.