0

I am trying to make a private ethereum network the only problem I am facing now is when I make multiple nodes on same pc they discover each other but when I tried to connect other pc on different network that pc was not able to connect to mine and it keep on logging "Looking for peers peercount=0"

I have tried 1:- Generating boot.key from bootnode and also passed my ip and port correctly in enode string 2:- adding the other pc enode string from admin.addPeer with the correct ip and port of that pc

I have tried all the solution listed on google but nothing seems to work, Iam only able to make nodes locally and connect them but with other pc on different network nodes are not connecting to each other

I have used the external Ip that we get from the google by typing "what is my ip"

Please Help!!

2
  • Are pcs in the same lan? If they are in separate lans likely you will have to configure firewall or port redirections so one can connect to the p2p port from the other.
    – Ismael
    Dec 28 '20 at 15:27
  • No my Pcs are on different network and I have disabled my firewall and also configured my router for port forwarding but I think my local port are still not accessible by my public ip Dec 29 '20 at 14:16
1

You should start geth process on both computers and check availability via RPC port (that you set in the geth params) using telnet or other same utils. It looks like the problem is accessibility by addresses and ports.

1
  • Yes I am not able to access my local port from my external ip ,I have also done port forwarding in my router but no success Dec 29 '20 at 14:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.