2

I am new to Ethereum. I cannot seem to use the geth cli on the testnet.

geth and the GUI (synchronized with the testnet) work, but when I try to to get --testnet, I get:

dyn1237-76:eth1 sam$ geth --testnet
I1007 19:26:19.868747 ethdb/database.go:83] Alloted 128MB cache and 1024 file handles to /Users/sam/Library/Ethereum/testnet/chaindata
Fatal: Could not open database: resource temporarily unavailable

(I m on a OSX El capitan). Can anyone help please?

  • Do you already have an instance of geth or GUI running? If so, stop it and then try geth --testnet, since only one instance is allowed. – eth Oct 7 '16 at 18:59
2

problem

This error is caused by a process who use this folder/chain. Perhaps you've runned a previous geth client which is still alive in the background.

Solution

stop geth process or try to attach to it by typing:

$ geth attach

in your command line. This will allow you to communicate with the geth client through a console.

2

I had this problem too at one point. The best thing to do is to stop everything and restart your computer. This will stop all Ethereum processes. You could kill processes using the task manager / command line but this will be easier to do and it will ensure you do not kill important processes not related to Ethereum.

Once you restart, re-run the GUI. If you still get the same error then I suggest (PLEASE ONLY DO THIS IF YOU DO NOT NEED YOUR CURRENT ETHEREUM ACCOUNT IN CASE YOU INCUR LOSS OF DATA OR FUNDS) that you uninstall Ethereum. Then go to your folder C:\Users*YOURUSERNAME*\AppData\Roaming\ and delete the Ethereum folders. You may need to restart you computer again before you can do this to ensure no ethereum processes are running after you tried to re-run Ethereum.

Once this is done, re-install Ethereum, let it resync the blockchain and then you're good to go. One tip... never close the ethereum GUI using the X button, instead click 'Ethereum' and 'Quit Wallet'. This will end the processes without leaving them running in the background and locking your folders.

Hope that helps!

  • Welcome to the community! Thanks for yor first post and this detailed answer. – eth Oct 8 '16 at 14:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.