2

My system:

OS: ubuntu 16.04
python version: 2.7

I am following the instructions from here : https://github.com/ethereum/pyethapp/wiki/Getting-Started to install pyethapp from Github. However when I tried to run pyethapp, it shows this error message:

"sorry, but this version only supports 100 named groups"
AssertionError: sorry, but this version only supports 100 named groups

I know this has something to deal particularly with my machine and regex but I am unable to solve it.

1

This is a recent bug in pycparser: https://github.com/pyca/cryptography/issues/3187. There are two workarounds you can try:

pip install pycparser==2.13

or if you don't want to downgrade the pycparser:

pip install cryptography --no-binary pycparser

  • Thanks for the reply. By running the first command, the previous error resolved(perhaps) but now I find a new assertion error for all peers when I run pyethapp. The error message I get now is the same error message that I mentioned secondly in link while installing pyethapp by PyPI. How to resolve this now :/ – shikhar mahajan Oct 6 '16 at 14:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.