2

I'm unable to run any commands after setting up clef and geth on the Görli chain.

geth attach /path/to/clef.ipc
Welcome to the Geth JavaScript console!

 modules: account:1.0 rpc:1.0

> eth.getBalance("0x8e3097A24838d7C11efd79F93c90Fa4Eb5a97C99", "ether")
Error: the method eth_getBalance does not exist/is not available
    at web3.js:6347:37(47)
    at web3.js:5081:62(37)
    at <eval>:1:15(5)

Any help would be greatly appreciated. I'm very new to all of this. Thanks for your time.

Following the getting started steps on geth and Görli: https://geth.ethereum.org/docs/getting-started. These are the exact steps and output:

  • created 2 accounts in clef
  • run clef against my keystore: clef --keystore /path/to/keystore --chainid 5
WARNING!

Clef is an account management tool. It may, like any software, contain bugs.

Please take care to
- backup your keystore files,
- verify that the keystore(s) can be opened with your password.

Clef is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY;
without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
PURPOSE. See the GNU General Public License for more details.

Enter 'ok' to proceed:
> ok

INFO [10-21|16:02:31.229] Using CLI as UI-channel
INFO [10-21|16:02:31.397] Loaded 4byte database                    embeds=146841 locals=0 local=./4byte-custom.json
## Master Password

Please enter the password to decrypt the master seed
>
-----------------------
INFO [10-21|16:02:33.013] Starting signer                          chainid=5 keystore=/path/to/keystore light-kdf=false advanced=false
DEBUG[10-21|16:02:33.013] FS scan times                            list="255.496µs" set="14.219µs" diff="15.4µs"
DEBUG[10-21|16:02:33.024] Ledger support enabled
DEBUG[10-21|16:02:33.026] Trezor support enabled via HID
DEBUG[10-21|16:02:33.027] Trezor support enabled via WebUSB
INFO [10-21|16:02:33.028] Audit logs configured                    file=audit.log
DEBUG[10-21|16:02:33.028] IPC registered                           namespace=account
INFO [10-21|16:02:33.028] IPC endpoint opened                      url=/path/to/clef.ipc
------- Signer info -------
* intapi_version : 7.0.1
* extapi_version : 6.1.0
* extapi_http : n/a
* extapi_ipc : /path/to/clef.ipc
  • run geth: geth --goerli --syncmode "light" --signer=/path/to/clef.ipc
INFO [10-21|16:05:47.030] Starting Geth on Görli testnet...
INFO [10-21|16:05:47.030] Dropping default light client cache      provided=1024 updated=128
INFO [10-21|16:05:47.031] Maximum peer count                       ETH=0 LES=10 total=50
INFO [10-21|16:05:47.031] Using external signer                    url=/path/to/clef.ipc
INFO [10-21|16:05:47.033] Set global gas cap                       cap=25000000
INFO [10-21|16:05:47.033] Allocated cache and file handles         database=~/Library/Ethereum/goerli/geth/lightchaindata cache=64.00MiB handles=5120
INFO [10-21|16:05:47.074] Allocated cache and file handles         database=~/Library/Ethereum/goerli/geth/lespay cache=16.00MiB handles=16
INFO [10-21|16:05:47.134] Persisted trie from memory database      nodes=361 size=51.17KiB time="935.06µs" gcnodes=0 gcsize=0.00B gctime=0s livenodes=1 livesize=0.00B
INFO [10-21|16:05:47.135] Initialised chain configuration          config="{ChainID: 5 Homestead: 0 DAO: <nil> DAOSupport: true EIP150: 0 EIP155: 0 EIP158: 0 Byzantium: 0 Constantinople: 0 Petersburg: 0 Istanbul: 1561651, Muir Glacier: <nil>, YOLO v1: <nil>, Engine: clique}"
INFO [10-21|16:05:47.137] Added trusted checkpoint                 block=3538943 hash="ff3ae3…d375f2"
INFO [10-21|16:05:47.137] Loaded most recent local header          number=0 hash="bf7e33…b88c1a" td=1 age=1y9mo9h
INFO [10-21|16:05:47.137] Configured checkpoint registrar          address=0x18CA0E045F0D772a851BC7e48357Bcaab0a0795D signers=5 threshold=2
INFO [10-21|16:05:47.138] Starting peer-to-peer node               instance=Geth/v1.9.23-stable/darwin-amd64/go1.15.2
INFO [10-21|16:05:47.201] UDP listener up                          net=enode://e562ddd8103347f6df44468cd9d52400314975992a86cd2b2f8f612ff0ef5a7d5d650ae0d24d48cb2effa589d04241a50ca78f71d258c32a4c6d845051fc30e1@[::]:30303
2

This command line is wrong : geth attach /path/to/clef.ipc.

You have to use instead : geth attach <IPC_LOCATION>. You should find in your goerli repository a geth.ipc file. It could be a hidden file so don't hesitate to ls -a to see it. IPC_LOCATION is the path to this file.

To connect to the ipc console the command is therefore :

geth attach /PATH/geth.ipc

You should see the following APIs available : modules: admin:1.0 clique:1.0 debug:1.0 eth:1.0 les:1.0 lespay:1.0 net:1.0 personal:1.0 rpc:1.0 txpool:1.0 web3:1.0.

5
  • I tried adding these to this command: geth --goerli --syncmode "light" --signer=/path/to/clef.ipc --rpcapi --rpcapi="eth,net,web3,personal,admin,miner". Then I ran geth attach /path/to/clef.ipc but I still see the same output modules: account:1.0 rpc:1.0 – abigpotostew Oct 22 '20 at 17:06
  • I read to fast your question and didn't see you were connecting to Geth with IPC. I changed my answer, please tell me if it worked. – clement Oct 23 '20 at 9:30
  • My original answer was true for rpc connection, not ipc. Note that with ipc you have many APIs available by default which is not the case with rpc or ws, because of security considerations. – clement Oct 23 '20 at 9:33
  • *I read too fast – clement Oct 23 '20 at 10:15
  • Using the geth.ipc file works. Thank you @clement – abigpotostew Oct 25 '20 at 0:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.