3

I have tried to run the example of Web3Modal on my local env, and then use IMToken to scan the QRcode showed by clicking the WalletConnect, but at last I just got an error which is showing below:

https://user-images.githubusercontent.com/6203602/94316022-31a13280-ffb6-11ea-9ec0-46cba91205a9.png

Please suggest me a possible solution about this issue and please let me know what else code you want me to provide, thanks!

BTW, I have tried using different infuraId to init Web3, but got same error, even if I used the id from live demo site of web3modal

Example link

3

I discovered the same issue. It's a known bug in web3.js v1.3.0 that was brought in this PR: #3649. In this comment someone explains it in more detail.

There is an ongoing PR here that will fix it, so i'd suggest to keep an eye on that one.

A temporary solution would be to downgrade to web3 v1.2.11

1
  • Works, thanks a lot!
    – llp
    Sep 29 '20 at 13:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.