0

I am currently trying to run a test node, which recently failed. I have deleted the directory and copied another node's AND tried a reset of the directory but at some point it freezes with this log and doesn't sync anything.

WARN [09-28|13:44:35.921] Header broke chain ancestry              peer=b0ac3a6413bad392 number=160226 hash="9b9eef…43ffb3"
INFO [09-28|13:44:35.931] Downloader queue stats                   receiptTasks=0 blockTasks=0 itemSize=0.00B throttle=8192
WARN [09-28|13:44:35.931] Synchronisation failed, dropping peer    peer=b0ac3a6413bad392 err="retrieved hash chain is invalid: no peers available or all tried for download"

I have tried to recompile Geth but it didn't solve my problem. For reference here is my command: ./build/bin/geth --datadir chain/ --networkid 15 --http.addr 0.0.0.0 --http.api "eth, net, web3" --http --http.port 6786 --miner.gasprice 10000000000 --syncmode full --bootnodes enode://<long number>@127.0.0.1:35665 --gcmode archive

  • Update: My problem has been fixed after letting the node sync for a few hours (the distance was 8), but I would still like an answer where for a long time the sync has not sent anything and may also help others. Thank you. – smileycreations15 Sep 28 at 12:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.