0

I hope you're alright and safe there.

I'm trying to set up a private Ethereum network and bind it to Hyperledger Caliper. However, I couldn't sufficient sources to do that. Recently, I used geth v1.19 Ethereum client and created two nodes, initialised them with the same genesis.json file. But I couldn't go beyond that point. I tried to bind it to Caliper and the error I got as the following.

ethereum@ethereum-VirtualBox:~/caliper-benchmarks$ npx caliper launch master --caliper-workspace . --caliper-benchconfig benchmarks/scenario/simple/config.yaml --caliper-networkconfig networks/ethereum/1node/ethereum.json 2020.09.26-02:18:31.025 info [caliper] [cli-launch-master] Set workspace path: /home/ethereum/caliper-benchmarks 2020.09.26-02:18:31.028 info [caliper] [cli-launch-master] Set benchmark configuration path: /home/ethereum/caliper-benchmarks/benchmarks/scenario/simple/config.yaml 2020.09.26-02:18:31.029 info [caliper] [cli-launch-master] Set network configuration path: /home/ethereum/caliper-benchmarks/networks/ethereum/1node/ethereum.json 2020.09.26-02:18:31.029 info [caliper] [cli-launch-master] Set SUT type: ethereum 2020.09.26-02:18:32.106 info [caliper] [benchmark-validator] No observer specified, will default to none 2020.09.26-02:18:32.106 info [caliper] [caliper-engine] Starting benchmark flow 2020.09.26-02:18:32.154 error [caliper] [cli-launch-master] Unexpected error during benchmark execution: Error: Ethereum benchmarks must not use http(s) RPC connections, as there is no way to guarantee the order of submitted transactions when using other transports. For more information, please see https://github.com/hyperledger/caliper/issues/776#issuecomment-624771622

I may not achieve to set up a proper private Ethereum network for Caliper. I would be grateful if you could help me out with testing the private Ethereum network with Caliper.

My email: znkcn2000@gmail.com

Best regards,

0

Go to the network settings file (networks/ethereum/1node/ethereum.json) and replace the following line

"url": "http://localhost:8545",

with

"url": "ws://localhost:8545",

Make sure you use the correct port number.

Good Luck

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.