4

Total newbie here. I am trying to get my blockchain synced again after the Geth Node issue of Sept. 18. I am stuck on block #2283419. I am running Mist 8.2 and Ethereum Wallet 8.2. Node connects but won't download. I am running Mac OSX 10.9.5 Ethereum blog mentioned a hotfix and I downloaded both files but blockchain still stalled on that block. I am not a programmer and have only basic computer skills. Please "dummy down" the answer for me. I do have my keystore file backed up just in case I need to resinstall programs. Thanks in advance. Bill

  • What operating system are you using? You may not have installed the new version of geth correctly. You could install parity or wait until new version of mist is released. Don't worry your coins are safe – bamos Sep 20 '16 at 1:50
  • I am using OSX 10.9.5. Should I have downloaded the two 1.4.12 files into the MIst folder? As long as my coins are safe, i can wait till the new Mist version comes out.... Thanks!! – BillPA Sep 20 '16 at 2:44
  • I'm encountering the same problem (on OSX 10.10.5). I installed "Mist 0.8.3" but have not been able to download anymore blocks. Also installed "Ethereum-Wallet 0.8.3" (given I used to use "Ethereum-Wallet" until 0.8.2 automatically changed this to "Mist") with the same result. – user3962 Sep 20 '16 at 14:52
2

A new version of Ethereum Wallet 0.8.3 with geth 1.4.12 has been released at https://github.com/ethereum/mist/releases/tag/0.8.3, with the following message:

Security fix

This Mist & Wallet 0.8.3 release contains the updated 1.4.12 Geth version. If you were experiencing issues with Mist crashing after block 2283416, then that's the likely culprit.

Just install the new .dmg file and your old version show be overwritten.

This new version has synced past block #2283419:

enter image description here

geth v1.4.12 is packaged with the Ethereum Wallet:

Iota:nodes user$ pwd
/Applications/Ethereum Wallet.app/Contents/nodes/geth/mac-x64
Iota:nodes user$ ./geth version
Geth
Version: 1.4.12-stable-421df866
Protocol Versions: [63 62]
Network Id: 1
Go Version: go1.7
OS: darwin
GOPATH=
GOROOT=/usr/local/go

I also have geth v1.4.11 installed on another path. Ethereum Wallet will execute geth v1.4.12 from it's subdirectory (see above) if you have not already started geth from your command line.:

Iota:mac-x64 user$ which geth
/usr/local/bin/geth
Iota:mac-x64 user$ geth version
Geth
Version: 1.4.11-stable-fed692f6
Protocol Versions: [63 62]
Network Id: 1
Go Version: go1.6
OS: darwin
GOPATH=
GOROOT=/usr/local/Cellar/go/1.6/libexec


I've Updated To The Latest Version Of Ethereum Wallet And geth But My Chain Is Still Not Syncing

Check that you have the latest Ethereum Wallet and geth. You may have geth installed in several different place on your computer. If so, make sure your are running the 1.4.12 version and not an older version.

Note that currently geth 1.5 has the memory bug fixed 2 days ago - if you built geth 1.5 from source, you have to re-download the source code and rebuild it. If you installed it using the dev package, it is likely that this package has not been updated. Remove the dev package and try again.

If you need to downgrade from 1.5, see Downgrade to 1.4.12 (if necessary) (for Ubuntu).

You may have to remove (or rename) your old chaindata directory and restart Ethereum Wallet. When you restart Ethereum Wallet, it will instruct geth to re-sync the chain using the --fast parameter so your blockchain data will be smaller.

To remove your old chaindata directory, see How to delete or reset the blockchain in geth? (OSX) .

Not the answer you're looking for? Browse other questions tagged or ask your own question.