4

I have a problem with my Ethereum Wallet. It was fully synchronized previously and constantly resynched while it was open and also after several shutdowns of the machine. Now, it suddenly stopped working and cant seem to find any peers. The strange thing is, it says its connecting to X peers everytime (in the little blue start screen) but then just cant download anything. When I open the application it says peers(no number)|880 blocks left|0%. That never changes. Only when I close and restart the application the number of blocks left jumps up. The application is responsive and all data (account, contracts) are still there. This started while I was actually using it. I had just created a contract on the main network and send a transaction to it. Both those transactions went through normally. Right after I send another transaction to this contract and right then it stopped synchronizing.

  • Its running on Linux Peppermint in a VM hosted with Virtualbox. I have restarted both the linux vm and the windows host. The Linux has internet, I am using a browser on it to post this question. The problem has persisted over several hours now.
  • I have read somewhere that system time is an issue. I am new to Linux but I am fairly sure that the system time is synchronized. To check I have set the system time to "manual" and entered a random time. Saved, closed, and reopened, set it to automatic again and it automatically set the correct time. I am assuming this time must have come from some time server.
  • Geth is not running in another instance. I have checked with both ps and killall.
  • I have tried starting geth through the terminal. It says two different things:

    Peer de471bccee3d0422 [eth/63]: timed out DAO fork-check, dropping

    which I googled and found to be just a peer using incompatible software, and:

    converting 1600000 canonical numbers...

    Increasing the number in steps of 100000. There were a few of both these messages but nothing else after like half an hour.

At this point, I have no clue what the problem is or what else I could do to figure it out. What can I do to get it working again?

2

I am having trouble too. I think it may be due to a geth bug:

https://blog.ethereum.org/2016/09/18/security-alert-geth-nodes-crash-due-memory-bug/

I think we may need to wait for a new version of geth / mist wallet to be released?

Edit: I ran mist wallet on windows, while trying to sync beyond block 2283415, and watched the geth process start eating memory, past 13GB, until the geth process just dies.

  • Yes, thats it! Geth is stuck on exactly that block. But how do I update it? Checking for updates for the Ethereum Wallets doesnt help, it says I am using the newest version already – Max Binnewies Sep 19 '16 at 17:26
  • Unfortunately at this point you need to get the new geth source compiled, and overwrite your mist geth executable I believe. github.com/ethereum/go-ethereum/releases/tag/v1.4.12 – Alex Martin Sep 19 '16 at 20:58
  • Updated Mist: github.com/ethereum/mist/releases/tag/0.8.3 – Alex Martin Sep 20 '16 at 16:36
  • Its still not working! I replaced my ethereum wallet with new release 1.4.12 and it still has the exact same problem. I also tried parity(which was supposed to be unaffected) and it too gets stuck at block 2283415... – Max Binnewies Sep 20 '16 at 21:03
  • You may need to delete your blockchain data and resync from scratch? I will try this on my windows install later and post back. – Alex Martin Sep 20 '16 at 21:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.