I installed Geth for setup a ethereum node on my linux server and use it on my RPC API.

The problem is, Geth is posting "Looking for peers" forever, I don't really understand why. This is not a firewall problem, port 30303 TCP and UDP is allowed and works.

enter image description here

Here is my geth configuration:

geth --networkid 1 --http --http.port 6666 --http.api "personal, eth, web3" --datadir /root/.ethereum --syncmode fast --cache 2048 --nodiscover

My geth version is 1.9.20.

Thanks you for your help.

1 Answer 1


In my case it was fixed after setting time to use from NTP. "timedatectl set-ntp yes" is the command used.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.