8

The rinkeby faucet only seems to have an option for ether. I'd like some weth so I can test Uniswap v2. Anyone know where I can get some? Thanks!

2
  • 1
    I tried both: > sending ETH to WETH (in Rinkeby), which did not work > exchanging ETH for WETH in Uniswap, which only worked on Uniswap - in my Metamask account I still see 0 WETH. Any idea why this may be the case?
    – Mick m
    Mar 3, 2021 at 11:53
  • @Mickm Make sure you add the WETH token to MetaMask afterwards to see them in the "Assets" tab. Jan 28 at 9:30

4 Answers 4

6

As said previously, you can swap eth for weth on uniswap. But if you want, the smart contract address for weth in Rinkeby is 0xc778417E063141139Fce010982780140Aa0cD5Ab

5

Normal way would be as described by @Morten. Alternatively just purchase WETH with ETH at https://app.uniswap.org/#/swap.

3

You can simply send the Ether to the WETH contract, and it will send wrapped Ether back.

1

Before you do the swap ETH -> WETH, you cannot make the mistake of entering just "WETH". Some (scam?) coin called weth (whose logo is depicted below) will appar, but that is not the real WETH. Any funds sent there will be lost forever and not be returned as the WETH funds you want. Be sure to add the real WETH to your Metamask by searching for its address, as mentioned here before: 0xc778417E063141139Fce010982780140Aa0cD5Ab

False WETH that appears if you just type WETH into Metamask coin search

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.