1

I'm trying to test out Ampleforth on Rinkbey using Remix. Here are all the files that I copy into remix. https://github.com/cryptoghoulz/based-contracts/tree/master/contracts/v4

They compile fine, but when I deploy UFragments I get this error:

This contract may be abstract, not implement an abstract parent's methods completely or not invoke an inherited contract's constructor correctly.

Anyone know what could be going on? Thanks!

  • Yes: contract UFragments is ERC20Detailed, Ownable, and then contract ERC20Detailed is Initializable, IERC20. So you cannot deploy an instance of UFragments. You need to inherit this contract, and implement all functions not yet implemented (presumably, all of them are declared in IERC20). – goodvibration Aug 22 at 6:44
  • @goodvibration but UFragments implements all 6 functions in IERC20... – Richard Garfield Aug 22 at 19:15
  • Then look for other functions in other contracts which it inherits. – goodvibration Aug 22 at 19:23
  • I had a same error message. Have you solved it yet? Thanks @Richard Garfield – Terrance Nov 23 at 10:04
2

I had the wrong compiled file selected in the remix "deploy" drop down bar -_- for some reason the default file is the highest one in the hierarchy

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.