0

Lets say that I have the contracts A and B. A needs to make a delegatecall to B. A is (for some reason) compiled with a compiler version that is lower than B's compiler version.

Can I safely assume that A is still going to make the proper delegatecall to B and without any errors, complaints or security risks ?

  • 1
    I'm really not sure about it but I'd imagine them to be fully compatible. It's the bytecode that matters and if the EVM can run both then why couldn't both contracts be fully compatible with each other – Lauri Peltonen Jul 30 at 12:27
  • @LauriPeltonen just asking to double-check because I am not sure either... – Damir Olejar Jul 30 at 13:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.