0

I have initialized my own genesis block and started

geth --datadir pom 

Then I want to use "personal" so I started

geth --nodiscover --ipcpath pom/geth.ipc --networkid 31337 --rpc --rpcaddr 192.168.225.235 --rpcport 22000 --rpcapi admin,db,eth,debug,miner,net,shh,txpool,personal,web3,quorum,raft --port 21000

and I'm receiving the error

Fatal: Error starting protocol stack: genesis mismatch: 0xd4e56740f876aef8c010b86a40d5f56745a118d0906a34e69aec8c0db1cb8fa3 (leveldb) !=  (ancients)

I don't understand this error and I'm searching the google and some link says re initialize the chain. So I have deleted and initialize the genesis many times. Can someone help to solve this error? Thank you.

1

With

$ geth --datadir pom

you are not initializing a custom chain, you are just starting the client on the Mainnet using a custom folder.

To inizialize a custom network you need to use the init parameter with a genesis file, like this:

$ geth --datadir pom init [yourGenesisFile.json]

And after that you need to pass the custom folder value - pom in your case - even when running the client, so your command will become:

$ geth --datadir pom --nodiscover --ipcpath pom/geth.ipc --networkid 31337 --rpc --rpcaddr 192.168.225.235 --rpcport 22000 --rpcapi admin,db,eth,debug,miner,net,shh,txpool,personal,web3,quorum,raft --port 21000
1
  • I already done init. But I run as two command geth --datadir pom and in another command i try to attach ipc. But combine this to single command works – e.k Jul 27 '20 at 13:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.