I have been trying to connect remix to my machine and I have tried the following command:

remixd -s ./contracts --remix-ide http://remix.ethereum.org

Also, I have tried the https and other combinations which are mentioned here but, still I have not been able to connect to the remix and sometimes it shows me Connection from origin http://remix.ethereum.org rejected. but sometimes it doesn't mention if it has been connected to the remix or not.

I have tried both the old and new version of remix but the problem persists on both.

enter image description here

2 Answers 2


You should try httpS://remix.ethereum.org instead then


There are 2 important things :

1 - You should check the URL to be http://remix.ethereum.org

( Careful the address shouldn't have httpS:// )

2 - Also you must to change the local address from

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.