0

I had a small amount of ether stored in a wallet i downloaded from the appstore (on android). Unfortunately my phone broke and now I cant find the same app on the store anymore. I tried finding the app from the "my apps and games" page on google play but it seems like the app is no longer there on the store.

I had emailed myself the "private key" earlier as a backup just in case. The problem I am running into now is that the backup that I had done was simply clicking on the backup button on the app and emailing whatever file it generated to myself. I never checked the file or the key at the time.

Now that I see, the file has my ether address and a .key extension. I tried searching the internet and it said that it was an iOS keynote file, but keynote isn't able to access it either.

I'm trying to retrieve the either by linking it to a new metamask account by linking the private key. If someone could help me with if and how I can open the file I'd be really grateful.

Thanks in advance.

6
  • 1
    What's the length of the .key file? Is it a readable text file or random characters?
    – Ismael
    Jun 15 '20 at 16:39
  • The .key file is 514 bytes, unfortunately i can't find what program will be able to open the file so im not sure if the file has any text or random characters.
    – Dhaval
    Jun 16 '20 at 5:34
  • The extension don't say much about the app that generated. In any case the app should appear in your account's android library as previously installed. The size of the file is close to a JSON wallet (around 490), in metamask try "import account" and select the JSON format. Unfortunately without more clues it is hard to guess.
    – Ismael
    Jun 16 '20 at 6:57
  • Hey thanks a lot for your help! I already tried selecting the JSON format on metamask but it didn't work. I understand that its not possible without more clues. I am trying to find someone I personally know who has more knowledge about this, with whom I can share the file so maybe they can help. I'm sure you understand that I can't share the file itself since someone could use the private key to transfer the ether.
    – Dhaval
    Jun 16 '20 at 9:19
  • But anyway, once again thanks a lot for your help!
    – Dhaval
    Jun 16 '20 at 9:23
0

A hex editor will allow you to inspect the bytes in the file (any file), which may give clues about its format or structure.

There is a list of hex editors here, from which you may be able to select a suitable one for your operating system:

https://en.wikipedia.org/wiki/Comparison_of_hex_editors

Often the first few bytes in the file will give clues. For example, a sqlite3 database might contain the string "SQLite format 3", while a ZIP starts with the string "PK".

If you can install the "file" utility suggested in a comment, it can check the signature against the large set which it knows about.

If the first dozen or so bytes don't yield any obvious clues, the hex editor might still help you to start reasoning about the structure of the file. Readable characters may be visible in the ASCII column, and if you're lucky, you may be able to read the key directly from there. If not, it might still be possible to extract the private key from the hexadecimal column. The steps would be approximately:

  • Identify the sequence of bytes storing the key (my reading leads me to believe it would be 32 bytes)
  • Try transcribing them exactly as they are, removing spaces and adding "0x" at the beginning to indicate the hexadecimal format
  • Enter this string as the private key in the import prompt of your preferred wallet
  • If the resulting address isn't right, it may require adjustment for big-endian vs little-endian storage format, but it's also possible that it could be password protected. The rest of the file may give clues.

Good luck!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.