1

Trying to mine with Claymore v15.0 on a Radeon RX 580 GPU on Linux Ubuntu 20.04. I have recently upgraded Ubuntu from 16.04 to 20.04 and had extreme difficulty installing OpenCL. But once having done that, I am relatively sure that OpenCL is indeed working. I know this because I am CPU mining Monero with xmrig and I turned on the GPU option and it has been mining successfully for several uninterupted days.

I add this because Claymore v15.0 crashes my computer after about 3 minutes. (The xmrig miner is not running while I try Claymore.) I am using the same ethermine account I used while back on Ubuntu 16.04. I updated the same configuration from that era also.

Here is my shell script:

#export GPU_FORCE_64BIT_PTR=0
export GPU_MAX_HEAP_SIZE=100
export GPU_USE_SYNC_OBJECTS=1
export GPU_MAX_ALLOC_PERCENT=100
export GPU_SINGLE_ALLOC_PERCENT=100

./ethdcrminer64 -epool us1.ethermine.org:4444 -ewal 0xc539B4a9727F4Af781B016b18289eAA317f8b322.joe -epsw x -mode 1 -li 5 -lidag 2 -tt 80 -ttli 85 -tstop 90 -tstart 50 -r 180

I tried adding several parameters to control the temperature and trottle the speed. They make no difference and the miner crashes with or without those extra parameters. Below is the CLI session. I killed it so I can copy and paste before my computer crashes. I couldn’t help notice that the total speed is zero. Hashes per second is zero. I can only think I have misconfigured Claymore 15.0 or OpenCl is not as properly installed as I had thought. Or, my graphics card is bad – but that shouldn’t be as I’ve proved to myself it works while using it with xmrig. Thanks in advance for thinking with me.

����������������������������������������������������������������ͻ
�                Claymore's Dual GPU Miner - v15.0               �
�              ETH + DCR/SIA/LBC/PASC/BLAKE2S/KECCAK             �
����������������������������������������������������������������ͼ

ETH: 5 pools are specified
Main Ethereum pool is us1.ethermine.org:4444
At least 16 GB of Virtual Memory is required for multi-GPU systems
Make sure you defined GPU_MAX_ALLOC_PERCENT 100
Be careful with overclocking, use default clocks for first tests
Press "s" for current statistics, "0".."9" to turn on/off cards, "r" to reload pools, "e" or "d" to select current pool, "x" to select GPU, "z" to find best -dcri values
OpenCL initializing...

AMD Cards available: 1 
GPU #0: Ellesmere (Radeon RX 580 Series), 8000 MB available, 36 compute units (pci bus 65:0:0)
GPU #0 recognized as Radeon RX 480/580
POOL/SOLO version
AMD ADL library not found.
GPU #0: algorithm ASM 1
No NVIDIA CUDA GPUs detected.
Total cards: 1 

You can use "+" and "-" keys to achieve best ETH speed, see "FINE TUNING" section in Readme for details.

ETH: Stratum - connecting to 'us1.ethermine.org' <172.65.218.238> port 4444 (unsecure)
ETH: Stratum - Connected (us1.ethermine.org:4444) (unsecure)
ETH: Authorized
ETHEREUM-ONLY MINING MODE ENABLED (-mode 1)
ETH: eth-proxy stratum mode
Watchdog enabled
Remote management (READ-ONLY MODE) is enabled on port 3333

You did not specify -dcri values directly, so they will be detected automatically
Automatic detection of best -dcri values started, please wait...

Setting DAG epoch #341(3.66GB)...
ETH: 06/10/20-20:17:42 - New job from us1.ethermine.org:4444
ETH - Total Speed: 0.000 Mh/s, Total Shares: 0, Rejected: 0, Time: 00:00
ETH: GPU0 0.000 Mh/s
Setting DAG epoch #341 for GPU0
Create GPU buffer for GPU0
ETH: 06/10/20-20:17:46 - New job from us1.ethermine.org:4444
ETH - Total Speed: 0.000 Mh/s, Total Shares: 0, Rejected: 0, Time: 00:00
ETH: GPU0 0.000 Mh/s
ETH: 06/10/20-20:17:48 - New job from us1.ethermine.org:4444
ETH - Total Speed: 0.000 Mh/s, Total Shares: 0, Rejected: 0, Time: 00:00
ETH: GPU0 0.000 Mh/s
ETH: 06/10/20-20:17:48 - New job from us1.ethermine.org:4444
ETH - Total Speed: 0.000 Mh/s, Total Shares: 0, Rejected: 0, Time: 00:00
ETH: GPU0 0.000 Mh/s
Quit signal received...
Quit, please wait...
1

From what i know latest driver won't work with claymore (and other miners). You need to revert to the 18.04 ones. Here how it worked for me on Ubuntu 20.04 with RX580 8GB (same setup as you)

make sure you have hwe installed

sudo apt-get install --install-recommends linux-generic-hwe-20.04

make a backup of /etc/os-release and edit it.

sudo cp /etc/os-release ~
sudo nano /etc/os-release

Check for the VERSION_ID and change it from "20.04" to "18.04"

Make sure you remove previoulsy installed driver

amdgpu-pro-uninstall

The driver version 19.50 worked for me, try lower version if it fails. Download, Extract and install it:

wget https://drivers.amd.com/drivers/linux/19.50/amdgpu-pro-19.50-967956-ubuntu-18.04.tar.xz --referer https://support.amd.com/
tar -Jxvf amdgpu-pro-19.50-967956-ubuntu-18.04.tar.xz
cd amdgpu-pro-19.50-967956-ubuntu-18.04
./amdgpu-pro-install -y --opencl=pal,legacy,rocm --headless --no-dkms

Replace the original /etc/os-release file

mv ~/os-release /etc/os-release

Not sure about this but i did it, add yourself to the video and render group

sudo usermod -a -G video $LOGNAME
sudo usermod -a -G render $LOGNAME

Finally reboot

sudo reboot now

Even clinfo will tell your device are OpenCL capable and will detect them but for some reason the miner won't. Hope this works.

2
  • Thank you for the advice. Unfortunately, my computer does not boot. For a brief moment I see 3 text lines, I caught something about bus error. I am exploring ways to get a screen back. I think I have an old graphics card somewhere, I can try to replace that with the Radeon. Alternately, I can try booting from a USB thumb drive. Suggestions from the community would be appreciated. – JoeM Nov 22 '20 at 17:27
  • you should have amdgpu-pro-uninstall available at the command prompt. it will remove the drivers. Then reboot. – Louis Loudog Trottier Nov 23 '20 at 6:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.