0

I have a huge contract (which exceeds the default contract code size set in Quorum). I have increased the Code size and Transaction size in the Genesis file to 128Mb. The contract works well when deployed using Remix Browser, but shows BigNumber error when tried to interact with the contract deployed using web3.

Error:

    ERROR BigNumber Error: new BigNumber() not a base 16 number: 
    at raise (http://localhost:4602/vendor.js:279788:25)
    at http://localhost:4602/vendor.js:279776:33
    at new BigNumber (http://localhost:4602/vendor.js:278823:28)
    at SolidityTypeString.formatOutputString [as _outputFormatter] (http://localhost:4602/vendor.js:272577:19)
    at http://localhost:4602/vendor.js:273146:25
    at SolidityTypeString.push../node_modules/web3/lib/solidity/type.js.SolidityType.decode (http://localhost:4602/vendor.js:273147:11)
    at http://localhost:4602/vendor.js:272275:29
    at Array.map (<anonymous>)
    at SolidityCoder.push../node_modules/web3/lib/solidity/coder.js.SolidityCoder.decodeParams (http://localhost:4602/vendor.js:272274:26)
    at SolidityFunction.push../node_modules/web3/lib/web3/function.js.SolidityFunction.unpackOutput (http://localhost:4602/vendor.js:275757:24)

Can anyone please help me solve the issue.

  • Error: - error of what??? – goodvibration May 25 at 13:52
  • And if The contract works well when deployed, then: 1. Why does the title of your question ask how to deploy it? 2. What makes you think that the error has anything to do with its deployment? – goodvibration May 25 at 13:54
  • 1. I have specified How to deploy huge contracts 2. Because, when i deploy contracts through web3, i face issue only with huge contracts, all the other contracts work well. – Geethapriya G H May 25 at 14:39
  • There's ZERO code in your question, just a log dump of some error that you received. How exactly are you expecting anyone here to be able to help you with it????? – goodvibration May 25 at 14:42
  • 1
    @GeethapriyaGH What code do yo use to deploy? In web3 0.20 sometimes passing the number as string worked, ie instead of 1000 pass "1000". I don't think 128mb is particularly large (it fits in 32bits). It should be possible to deploy, but it might be some bug somewhere in web3 code. – Ismael May 26 at 17:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.