0

I have a Geth server which is fully synced, but the second server I have lunched cannot being synced after 2 weeks! I don't know why is this happening, but I decided to test another way.
I setup a new server and now, I would like to know how can I duplicate Geth server to have a new one?
For this purpose, I tried a way. I copied all geth and keystore directories from server 1 to server 2 via SCP in about 1 hour. Everything got finished and I ran the geth command, but I received the error below:

Fatal: Error starting protocol stack: gap (#9924668) in the chain between ancients and leveldb

I would be pleased if you can help me to know the appropriate way of having a duplicated server, or solving the issue mentioned above.

  • I don't know anything about duplicating Geth but just a note: if the other server can't get synchronized after 2 weeks it's quite possible it wouldn't stay synchronized even if you managed to duplicate all the data successfully so it would be a useless effort – Lauri Peltonen May 7 at 4:54
  • @LauriPeltonen, I had not such problem on server 1 and it got synced in 2 days, but after that, 2 times on 2 new servers I faced to this problem. I thought it might be a hardware issue for the the second server, so I removed server completely and setup a third one. But the problem did not solve. – Mohammad Saberi May 7 at 4:57
  • Are all of them using exactly the same hardware? – Lauri Peltonen May 7 at 5:04
  • @LauriPeltonen, yes all of them were the same, and in one datacenter – Mohammad Saberi May 7 at 5:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.