0

I have a Geth server on light mode, and implemented sending transactions based on web3.php project. Everything works well, except sending transactions.
The code I am using sends from, to, and value and other options like nonce, gas, and gasPrice left as their defaults and are not set. Transaction happens and I receive the TX hash, but when I explore it, there is not anything about it on the Ethereum blockchain.
This is an example:

https://etherscan.io/tx/0x46d52b2d8dea9cf2a98095324905bef8db7cd6556776d1d8a04c53a9a39c59b0

And this is the output in etherscan:

enter image description here
On the other hand, nothing happened on the sender address whereas I have received TX hash!

I'm sure that the sender address has enough fund to send and provide gas price. I'm really confused and cannot know what is the problem.

  • Your node is probably not fully synced. – goodvibration May 6 at 5:31
  • @goodvibration, eth.syncing is false – Mohammad Saberi May 6 at 6:11
  • And after some hour, a strange behavior on Ethereum blockchain happened. The transaction which was unknown and there was not on the network, is succeed right now! I don't know how can I handle such behaviors on Ethereum blockchain – Mohammad Saberi May 6 at 8:46
  • Your node was definitely not fully synced. – goodvibration May 6 at 8:50
  • @goodvibration, how can I detect if my light node is fully synced? – Mohammad Saberi May 6 at 9:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.