0

Basically i'm using a cut and paste erc20 token code from this site:

https://hashnode.com/post/how-to-build-your-own-ethereum-based-erc20-token-and-launch-an-ico-in-next-20-minutes-cjbcpwzec01c93awtbij90uzn

NOT SURE IF THIS TEMPLATE IS IS OUTDATED OR NOT

i am not familiar with solidity, but learning atm

Also i'm using the remix IDE with the new interface


The error that i'm getting in the Remix IDE solidity compiler is:

ParserError: Expected identifier but got 'uint8' uint8 public decimal; 25; ^---^

1
  • I compiled the code in Remix selecting compiler 0.4.26 and it worked. – Ismael May 6 '20 at 0:18
0

That code is from 2017 and is kinda old. Find an updated code or just change the remix compiler version to 0.4.4 In order to change the compiler version, first chose the solidity compiler then at the top you can see a drop down menu for compiler, click it and chose the 0.4.4 compiler.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.