0

I have a strange issue with Geth. The code I've written is based on web3.php and worked well up to now. Currently, I'm testing sending ETH via sendTransaction() method. The operation finishs and I receive the txhash, but when I browse in in explorer, nothing appears regarding to this transaction!
This is the final result: https://etherscan.io/tx/0x820bdb5d81b8822eee95dee491763df34f24efbf82abc32f4002fbe9765559ba

I don't receive any error while sending transaction, and I got really confused why this problem happens :(
May you help me please?

Edit1: this is my code:

$from = 'SenderETHAddress';
$to = 'RecipientETHAddress';
$value = '0x38d7ea4c68000';
$GLOBALS['eth']->sendTransaction(['from'=>$from, 'to'=>$to, 'value'=>$value], function ($err, $data) {
    if ($err !== null) { 
        echo $err->getMessage();
        return;
    } else {
        print_r($data);
        return true;
    }
});

And I receive the txhash in result of operation. One of received results was:
0x820bdb5d81b8822eee95dee491763df34f24efbf82abc32f4002fbe9765559ba

Edit2:
I also tried sendind ETH through Geth itself via its console. I ran:

eth.sendTransaction({
   from:'0x33D8A484e113480E37010201BF7569bDCb5fec33',
   to:'0xa96Ce4C161271C797d979017821A278e1481eAfA',
   value: web3.toWei(0.00001, "ether")
})

And this was the result:

"0x922636876cb53d44933e81eb99b0d67a5067b591779bc83b491c37ddf0cfe178"

But again, there is nothing related to this transaction hash on the network!

  • There is no transaction in this link! – goodvibration Apr 12 at 10:29
  • I know. This is why I wrote this question. – Mohammad Saberi Apr 12 at 10:31
  • The operation finishes - how exactly are we supposed to guess what operation you've executed, and how you've executed it? – goodvibration Apr 12 at 10:32
  • I added the code I have, I hope it can help you to know what is the operation. – Mohammad Saberi Apr 12 at 10:56
  • What node do you connect your web3 to? – goodvibration Apr 12 at 11:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.