4

My apologies if this has been covered elsewhere, but I several different guides and sources, both "official" documentation and not, about how to get started for mining. I feel I have followed the instructions to the best of my ability, but I feel like I am spinning my wheels in the mud here.

I downloaded the following: Ethereum Wallet (had a link here, can't post more than 2 links without 10 rep?really?) cpp-ethereum

then, I have been following this guide mainly, but do have others: http://www.ethdocs.org/en/latest/mining.html#mining

so, this is as far as I seem to be able to get: I open a cmd window in the folder with geth, and synced to the blockchain, or so I assume. I even created a second account, unsure of how to sync to my original I created when I opened the wallet app, so now I have two: (had an image here, won't let me post because I have less than 10 rep...really?)

and then I entered geth --rpc and that seemed to get me to the point where it was actively syncing to the blockchain.

I then tried geth --rpc --rpccorsdomain and I still only get synced.

However, when I try to actually mine, I never seem to be able to get to that point.

I type geth ethminer -G and again, I seem to only get blockchain updates.

I then tried geth --opencl-device X where "x" is one of 0,1,2...to me this means that if I only have one GPU, it would be 0 right? so I tried --opencl-device 0.

Ultimately, no matter the input, this is what I get, for hours on end. I even went to bed and woke up hoping to find mining activity, and just the same thing: cmd view

I read on I think a subreddit page, that someone had a similar issue, and just like me, when they tried to open another cmd box simultaneously, they would get a "file is being used" error, and someone responded with "just close that cmd box, and open a new one, and it should work." I did just that, and I still get the same result.

Can someone please let me know what I am doing wrong here?

And ideally present me a solution that doesn't involve re-downloading packages from yet another source? Overall I am pretty frustrated right now, and yes, we are early adopters but my goodness, some consistency with the process etc would be really helpful. Thanks!

3

Don't use geth to mine, it won't really work.

Use something like Genoil ethminer 1.1.7

All you need to do is create an account for yourself (use Mist to do that), then join a mining pool like ethermine and you're off and running.

  • What do you mean it wont really work ? – dragosb Aug 19 '16 at 7:56
  • 1
    I mean it's functional, but not practical. Use a GPU-based miner like cpp-ethereum, or Genoil (a fork of cpp-ethereum). There are others as well, all significantly more performant than geth. – Ross Perkins Aug 19 '16 at 17:36
  • Thanks @RossPerkins . I am also able to solo mine via Genoil ethminer? – Joshua__c Aug 23 '16 at 4:09
  • 1
    @Joshua__c if you want to solo mine, you want to use geth + etherproxy + Genoil ethminer. You connect them like ethminer -> etherproxy -> geth. I do not recommend solo mining unless you have a LOT of GPUs, like hundreds of GPUs or more. – Ross Perkins Aug 23 '16 at 18:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.