0

The problem: I call a smart contract function on my local blockchain, then I confirm the transaction on metamask and finally the transaction is submitted but the transaction does not get mined.

On the blockchain console I receive the warning below:

WARN [03-26|18:21:48.169] Served eth_sendRawTransaction            conn=127.0.0.1:60092 reqid=1559115320157 t=213.552µs   err="already known"

Instead, when I disable metamask and I send a transaction with the unloacked account then the transaction get mined.

The strange thing that it used to work, I made many operations since yesterday.

Do you have any clue? Thanks!

  • Try resetting MetaMask – Ismael Mar 28 at 13:35
0

Thank you Ismael for your comment after much time spent with this error I have found that this error occurs when I reset my local geth node to the genesis block without resetting the account in meta mask. Now every time I want to start back from genesis I go into Meta Mask Settings => Advanced => Reset Account. This has worked for me I hope this helps you!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.