1

I tried to deploy and execute some transactions on multiple contracts but Metamask keeps showing 0 for the gas price and value field. I am on Ropsten test network. It is not specific to any contract, it is occurring on almost all contracts. Does anyone know the fix or the cause?

See screenshot, the below transaction is actually asking for 0.002 ethers from the account but it shows 0 here.

enter image description here

  • How are you executing the transaction? Web3? Remix? – João Quintanilha Mar 4 at 14:52
  • When I make deployment through remix, I face same issue. And when I execute write contract transactions through web3, same issue. – Fariha Abbasi Mar 4 at 15:14
  • Have you tried doing it for other testnet? like rinkeby or kovan? – João Quintanilha Mar 4 at 15:19
  • No I have only tested it on ropsten – Fariha Abbasi Mar 4 at 18:44
  • Try doing the same but just change the testnet, If the problem persists, check the parameters you are passing for the send_transaction method. Like the gasPrice/gasLimit. – João Quintanilha Mar 5 at 9:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.