0

I have initilize my node1 with my genesis file which worked fine command is 'geth --datadir node1/ init genesis.json'. But with same geth when I try to run this command



geth --datadir node1/ --syncmode 'full' --port 30311 --rpc --rpcaddr '0.0.0.0' --rpcport 8501 --rpcapi 'personal,db,eth,net,web3,txpool,admin,miner' --ws --wsaddr '0.0.0.0' --wsport 8601 --wsapi 'personal,db,eth,net,web3,txpool,miner,admin' --wsorigins * --rpccorsdomain *  --bootnodes 'enode://f6efbe327b816a3988517795dab11555e3b4488df1a146d37c885eecb40549da4fed1878ecd9fab0XXXXXXXXXXXXXXXXXXX2072f553bb51862ad78f8b13948de7cf02@127.0.0.1:0?discport=30310' --networkid 9XXX65 --gasprice '1'


To run the node then it provides me following error


invalid command: "node1"

Can anyone let me what is problem is about and how to resolve it? I am running it on AWS ec2 instance.

  • Try with ./node1 instead of node1/ – Florian Castelain Feb 20 at 10:19
  • @FlorianCastelain , I have tried all this method still getting same error . – Sahitya Kumar Suman Feb 20 at 11:00
  • It might be a problem with shell expansion of wildcards. Try escaping them or enclosing them in quotes geth ... --wsorigins "*" .... – Ismael Feb 20 at 14:08
0

You have a create node1 folder mkdir node1 first and then use ~/node1/

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.