0

I've tried to migrate contract on an older version of solidity, I have modified the config.js to be as in the following enter image description here

and the smart contract solidity code I'm trying to deploy as follows enter image description here

The problem is that whenever I try to migrate the contract it displays the following error. enter image description here

any recommendations?

1

Remove ^ from truffle-config.js.

You want to tell truffle which version to use. The "or higher" notion only applies to pragma in Solidity.

Hope it helps.

1
  • Thanks for your solution it's solved. – Amr Feb 7 '20 at 11:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.