I am using geth on windows with 1.9.10 version.

I used geth --rinkeby --rpc --rpcapi="personal,eth,network,web3,net" command for launch my geth.

I am on the Rinkeby testnet, i already transfer 3 ether through https://faucet.rinkeby.io/, to my 0xf80a5cd42ff3a5d154399c83376ce99323e3ff69 address. And on etherscan it also shows me that transaction has been done. But when I tried to see in the geth console through eth.getBalance(eth.account[0]) command, it showed me 0 balance. I tried too many times, but still it shows me 0 balance. When I try to eth.syncing, I am on the 3259367 current block and in my etherscan transaction block is 5846638. So why it's shows me 0 balance?

Do I need to Syncing all nodes till 5846638 in my local computer ? or there are any thing that I am missing?

enter image description here

  • "Do I need to Syncing all nodes till 5846638 in my local computer?" Yes, this is the issue. You'll need to wait until you've fully synced. Commented Jan 24, 2020 at 8:25

1 Answer 1


When you sync your node, It fetches data previously written on the Blockchain. Hypothetically, let's say that:

  • Node is currently syncing and had fetched the 100 first blocks
  • the first time your account was transferred some tokens were at the block 1000

In this scenario, at that precise point, if your node is still syncing, it won't have enough data to say that your account has some tokens. It will have to sync at least until the block 1000 to show that data. Hope this helps.

[EDIT] - Typos

Not the answer you're looking for? Browse other questions tagged or ask your own question.