I am using bootnode as a starting/meeting point for my private POA/clique network. When I start it since one of the latest versions it says:

fmt.Println("Note: you're using cmd/bootnode, a developer tool.")
fmt.Println("We recommend using a regular node as bootstrap node for production deployments.")

How can I prevent using a bootnode process and use a "boostrap node". I cannot find any details about that in the docs

1 Answer 1


The section Setting Up Networking here describes how to run a bootstrap node.

It looks like you just need to provide the flag --nat with the IP address of the computer/server running the code when you run the geth command. You need to make sure you have the port you are using open appropriately as well.

You can then use the geth console geth attach data/geth.ipc --exec admin.nodeInfo.enr to get the string other nodes should use to connect to your bootstrap node.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.