4

In order to set up the ethminer I need the MHash value. I'm testing CPU, so I ran:

ethminer -M

and I got a weird output:

Trial 1... 0
Trial 2... 0
Trial 3... 0
Trial 4... DAG  17:33:59.896|miner0  Generating DAG file. Progress: 0 %
0
Trial 5... 0
 ⚡   17:34:04.302|ethminer  Terminate worker 500 ms
min/mean/max: 0/0/0 H/s
inner mean: 0 H/s
Phoning home to find world ranking...

I have the DAG file generated and everything should be set up (I tried to mine setting a number and it did report hashes per second and stuff). So I'm not sure if the -M switch is not working properly or I'm doing something wrong, and I need the mhash value so I don't mess it up and end up losing money.

Thank you.

  • Can reproduce this, probably a bug. I also get 0 H/s using -M. – Afr Aug 6 '16 at 21:16
  • I read on another forum (irrelevant to mining) that some GPUs take time to warm up. Try running your benchmark with --benchmark-warmup 10. Good luck! – user9149 May 29 '17 at 5:30
1

You can use chfast's Fakeminer to do cpu benchmarks, see https://github.com/chfast/ethash/tree/master/test/fakeminer

| improve this answer | |
0

-M,--benchmark Benchmark for mining and exit; use with --cpu and --opencl.

Try with ethminer -M --cpu or ethminer -M --opencl depending on CPU / GPU benchmarking.

Edit : For some reason -M -G gives 0 hashrate while -G -M works. The ordering should ideally not matter, but maybe it does.

| improve this answer | |
0

You could try mining on a private Ethereum blockchain and look at how long it takes you to mine blocks as the difficulty rises. The hashing speed can then be calculated as hash_rate = difficulty / block_time_in_seconds. Alternately, you can mine on a pool or the test net (but I believe etiquette dictates you shouldn't mine on the test net for too long if you have an sizeable mining capacity -- which should be fine given you're testing a CPU). Pool mining is potentially less accurate.

See also How do I decrease the difficulty on a private testnet? if you want to try a private blockchain.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.