0

Getting this error" called function should be payable if you send value and the value you send should be less than your current balance" even when i set value

enter image description here

2
  • What function are you calling? What parameters are you using?
    – Ismael
    Nov 15 '19 at 14:37
  • I am calling update function
    – shiva sai
    Nov 17 '19 at 6:10
1

Do:

function _callback(bytes32 queryid, ....) payable
{
...
}

You just need to append the word payable to the function.

1
  • if i add payable to that function it was showing me Overriding function changes state mutability from "nonpayable" to "payable". this error
    – shiva sai
    Nov 17 '19 at 6:10
1

You can't create oraclize-linked contract using "Javascript VM". Just because there is no oraclize contract there. Try to deploy the contract to the one of public testnets, for example, in Ropsten.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.