0

I have an Ubuntu instance running on aws ec2. I'm currently using Ubuntu server ec2 instance with the configuration as: 1 vCPU, 2.5 GHz, Intel Xeon Family, 1 GiB memory.
I'm running my Geth on this using command

geth --datadir ./Doc-Nodes --networkid 4780 --port 30306 --rpc --rpcapi "db,personal,eth,net,web3,debug,admin" --rpccorsdomain="*" --rpcaddr="0.0.0.0" --rpcport 8545 --allow-insecure-unlock console

The issue arises in the case of mining. Whenever I'm trying to mine the blocks on this instance using miner.start() , it gets stuck at for a long time.

Commit new mining work

While the same is working when I'm running the Geth locally on my machine.

What's the issue behind this? Do I need to increase the Ubuntu configurations?

Thanks.

  • Is this a PoW blockchain? The first time it has to generate the DAG for the proof of work it should take several minutes. If you can I'd try a PoA with a single validator. You can also add --verbosity 5 to have more logging to try to understand what is wrong. – Ismael Nov 2 '19 at 13:58
  • @Ismael Yes, it's a PoW. DAG has been already generated. I tried --verbosity 5 and it says that Ethereum handshake failed. Genesis block mismatch. Then I checked all these things mentioned here. Everything's correct. Once it starts working, I'll shift to PoA. – Prachi Sharma Nov 3 '19 at 11:09
  • The handshake failed seems unrelated more like some other node is trying to connect. Another possibility with PoW mining is that your difficulty is too high. – Ismael Nov 3 '19 at 13:41
  • @Ismael I tried it by reducing the difficulty, but is of no use. – Prachi Sharma Nov 4 '19 at 12:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.